java

Ik kreeg vandaag een melding van microsoft essential security dat er een virus was aangetroffen, ik verwijderde het en zag dat het een virus was dat door een lek in java op je pc kan komen (Blacole). Aangeraden werd dan ook de java te upgraden naar de nieuwste versie wat ik dan ook prompt deed. Omdat ik ook met eclipse werk heb ik ook de ontwikkelversie gedowload en zoals aangeraden de oude versies van java verwijderd. In rapid environment explorer heb ik alle paden naar java zoals JAVA_HOME gecontroleerde en als ik in de cmd intype java –version kwam er een mooi antwoord dat ik de juiste versie had en ook in mijn browser werkte het. Maar eclipse wou niet meer starten! Ik de nieuwste versie van eclipse geinstalleerd, maar ik bleef foutmeldingen krijgen. Aangeraden werd om –vm C:\Program Files\Java\jdk1.7.0_03\bin aan de eclipse.ini toe te voegen maar nog foutmeldigen. Alle paden gecontroleerd, nog eens geprobeerd om naar de jre7 installatie te verwijzen ipv naar de jdk maar dat bracht ook geen soelaas. Het viel me wel op dat naar jvm.dll werd verwezen die er helemaal niet bij zat. Toen kwam ik op een website die zei dat het lag aan de 64-bit versie van eclipse en de onjuiste (32-bit) versie van java. Ik had met java de x86 gedowload waarvan ik dacht dat dit de versie was voor 64-bit computers dus ik snapte er niks van. In oudere berichten zag ik dat sommige mensen met hun 64-bit internet browser de java niet zagen die ze nodig hadden. Ik snapte daar niks van want ik had toch aangeklikt de versie voor 64-bit en die zag ik dus staan toch? Ik met 64-bit browser de pagina openen en ik kreeg idd de melding bij controleren van java dat ik geen java had. Er werd me aangeraden de jdk 1.6 te installeren, maar die wou ik niet, ik wou de 1.7. Ik keek nog eens goed achter de download van de jdk 1.6 en er stond dus x64 achter en niet i586 zoals de versies die ik eerder had geïnstalleerd. Nog eens gedownload nu en geïnstalleerd en nu heb ik een installatie in C:\Program Files\Java\jdk1.7.0_03\bin (dus niet in de x86 map!). Hierna werkte eclipse dus perfect weer. Ik had dus kennelijk de 32-bit en niet de 64-bit gedowload omdat ik als noob niet snap hoe dat zit met die x86 en x64

Advertenties